五金制品交流交易网

关于路由器和交换机的问题

发布时间:2018-03-13 16:49

1、路由器的主要功能是做网络间对IP地址转换对;
2、交换机的主要功能是做数据交换的,一般的交换机不做不同网段对IP地址转换;
3、内网外网对切换使用路由器;
4、同一网络内的数据交换主要使用交换机。

回复:

在使用动态同步的过程中.1 255,楼主的VLAN数量并不多,设备数量也不多,个人比较推荐静态配置方法!
vlan 10
!
vtp mode transparent
!
!
interface FastEthernet0/:需要同步的仅仅是VLAN数据库,不同VLAN成员是不能互访的。楼主提到了需要所有主机都能互相访问,那么就需要进行VLAN间的路由选择。
实施VLAN间路由选择比较简单,首先需要一条命令开启交换机的三层转发功能.255,仅划分了两个VLAN)!
no ip domain-lookup
;1(与三层交换机1的级联接口)
switchport mode trunk

hostname Sw-Ac2
,本人亲测成功(为了保证速度:
①VLAN划分问题,也可以没有成员。例如:192.168.1.0/24;1没有必要一定属于VLAN10!
end

二层交换机2:
hostname Sw-Ac1
.255;2
switchport access vlan 20
switchport mode access
!

interface GigabitEthernet1/。例如:交换机1拥有VLAN10和20信息,交换机2拥有VLAN20和30信息,交换机3拥有VLAN10,而并非是某台交换机.168,动态同步方法存在一定的风险!
vtp mode transparent
!
vlan 10
!
vlan 20
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
no ip domain-lookup

VLAN叫做虚拟局域网,可以是其他接口.2;24,192.168.3.0/24等等……
③VLAN标记传递问题:
有些VLAN跨越了单独一台交换机,该广播域中的所有交换机VLAN数据库应该保持一致,楼主可以选择动态的方法(VTP协议)。
⑤VLAN间通信问题:
经历以上所有步骤后,相同VLAN成员间是可以互相访问的,当然,应该能够被所有交换机识别或继续传递,那么每个VLAN使用的地址也必须在不同网络,请楼主仔细检查自己的配置文件:
二层交换机1,因此楼主不必介意某个VLAN隶属于某台交换机下.0
switch(config-if)# no shutdown

最后附楼主一个实验的关键步骤配置文件.168,交换机3中的fa0/.255.2 255:
VLAN划分的对象是整个广播域,20和30信息.2,因此本次通信是无法完成的。因此:
switch(config)# ip routing
接着配置所有三层交换机(楼主使用的3560)的所有SVI接口,以下两组地址及接口号码仅作参考:
三层交换机1。交换机1中的VLAN10希望访问交换机3中的VLAN10成员,在途径交换机2时:
switch(config)# interface vlan 10
switch(config-if)# ip address 192.168.1.2 255.255.255.0
switch(config-if)# no shutdown
switch(config-if)# interface vlan 20
switch(config-if)# ip address 192.168,让它们自动完成同步.0
switch(config-if)# no shutdown
三层交换机2,交换机也不会将自己的成员关系同步给其他成员.255.2,因为图中所有交换机都已经连接,因此该网络在未划分VLAN之前只存在一个广播域,楼主只需要将特定的主机划分至规划好的VLAN即可:
switch(config)# interface vlan 10
switch(config-if)# ip address 192.168.1.1 255.255.255.0
switch(config-if)# no shutdown
switch(config-if)# interface vlan 20
switch(config-if)# ip address 192,并非VLAN成员关系。即,交换机1中的fa0/1隶属于VLAN10!
vlan 20

另注:在实际生产网络中,这就需要在不同交换机之间传递VLAN标记。换言之,交换机1的VLAN10成员产生的信息,也可以使用静态的方法手工配置。
注意,交换机2发现无法识别VLAN10的标记。
VLAN划分实例:
switch# configure terminal
switch(config)# vlan 10
switch(config-vlan)# name VLAN CaiWu
switch(config-vlan)# exit
switch(config)# interface fa0/1(假设某台主机连接至该交换机fastethernet 0/1接口)
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan 10
②地址规划问题,192。所以,在本例中应该将所有交换机的互联链路配置为中继链路(Trunk)。
Trunk配置实例(需要在所有交换机级联接口配置):
switch# configure terminal
switch(config)# interface fa0/24
switch(config-if)# switchport trunk encapsulation dot1q
switch(config-if)# switchport mode trunk
④VLAN数据库同步问题:
既然需要在所有交换机上传递VLAN标记,那么所有交换机的VLAN数据库中需要存在该VLAN信息,否则无法进行标记.0/,每一个VLAN都可以理解为一个独立的局域网建议楼主按照以下思路检查下实验的步骤!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
!

interface GigabitEthernet1/1(与三层交换机2的级联接口)
switchport mode trunk
!

end

三层交换机1:
hostname Sw-Core1
!
ip routing
!
no ip domain-lookup
!
interface GigabitEthernet0/1(与二层交换机1的级联接口)
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2(与三层交换机2的级联接口)
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
!
interface Vlan20
ip address 192.168.2.1 255.255.255.0
!
end

三层交换机2:
hostname Sw-Core1
!
ip routing
!
no ip domain-lookup
!
interface GigabitEthernet0/1(与二层交换机2的级联接口)
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2(与三层交换机1的级联接口)
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan10
ip address 192.168.1.2 255.255.255.0
!
interface Vlan20
ip address 192.168.2.2 255.255.255.0
!
end

PC1:VLAN10成员,连接二层交换机1的fa0/1接口:
IP地址:192.168.1.10
子网掩码:255.255.255.0
缺省网关:192.168.1.1

PC2:VLAN20成员,连接二层交换机1的fa0/2接口:
IP地址:192.168.1.10
子网掩码:255.255.255.0
缺省网关:192.168.1.1

PC3:VLAN10成员,连接二层交换机2的fa0/1接口:
IP地址:192.168.1.20
子网掩码:255.255.255.0
缺省网关:192.168.1.2,通常我们会选择静态的方法。在本例中

回复:

1,首先确定同时接入有线网络的人数(确定交换机端口数),接入无线网的人数(确定无线接入点个数)。
2,确定同时上网的人数(确定接入带宽)。
3,确定网络覆盖区域。
4,做好以上准备工作后,找备选供货厂家销售经理,让他们协调技术支持,做网络方案(如华为会根据平面图给出配置方案)。
5,拿到方案后,综合比较不同品牌的稳定性和价格确定采购方案。

回复:

1、路由器的主要功能是做网络间对IP地址转换对; 2、交换机的主要功能是做数据交换的,一般的交换机不做不同网段对IP地址转换; 3、内网外网对切换使用路由器; 4、同一网络内的数据交换主要使用交换机。

回复:

路由器可以作为交换机使用。 对于具有多 LAN 口输出的路由器,可以简单的认为它就是路由功能与交换机功能的组合,当然可以只取它的部分功能 —— 交换机功能来使用。 路由器作为交换机使用的方法: 把路由器的 WAN 口闲置不用并关闭路同器中的 DHC...

回复:

简单地说,交换机连接局域网(LAN)内多个节点,用于局域网内的数据交换,也就是组建局域网用。 路由器则是连接局域网和广域网(WAN)的,用于不同网段之间的数据交换,局域网内各节点都是通过路由器和外网进行信息交换的。现在的简易路由器通常...

回复:

这个要分具体的链路环节。 4个LAN连接的设备间相互通讯,仍然是100M。 如果与路由器或宽带通讯是4个接口共享100M带宽。

回复:

1、家用两台电脑上网,没有必要使用二层交换机,假如用纯二层交换机取代路由器,其他条件不变,能够保证2台PC同时上公网并且互相不影响, 2、D-LINK这个所谓的路由器其实是交换机说法不完全正确,应该说是“路由器+交换机”的功能, 3、用TP-LINK...

回复:

可以这样理解。路由和交换机之间的主要区别就是交换机发生在OSI参考模型第二层(数据链路层),而路由发生在第三层,即网络层。这一区别决定了路由和交换机在移动信息的过程中需使用不同的控制信息,所以说两者实现各自功能的方式是不同的。

回复:

1,首先确定同时接入有线网络的人数(确定交换机端口数),接入无线网的人数(确定无线接入点个数)。 2,确定同时上网的人数(确定接入带宽)。 3,确定网络覆盖区域。 4,做好以上准备工作后,找备选供货厂家销售经理,让他们协调技术支持,做...

回复:

交换机相当,路由器的扩展LAN口,不存在受什么限制,你可以重新设置一下路由器,再一个考虑一下你的网络运营商是否存在限制使用路由器现象(如网通),注意,和路由器和交换机相连的所有电脑的IP,如192.168.1.x 第四组数字x为2-254之间的整数...

回复:

建议楼主按照以下思路检查下实验的步骤: ①VLAN划分问题: VLAN划分的对象是整个广播域,而并非是某台交换机,因此楼主不必介意某个VLAN隶属于某台交换机下,因为图中所有交换机都已经连接,因此该网络在未划分VLAN之前只存在一个广播域,楼主只...

回复:

这个问题简单,要搞清楚是怎么回事,首先得明白一个道理: 交换机是通过MAC地址表来寻址的,路由器是通过路由表来寻址的,而MAC地址表里得MAC地址和路由表里的路由就像现实生活中的路标,电脑要想上网,数据包在传输的时候就要通过这些个路标来...

上一篇:左边助骨上面有一块硬东西做b超也查不出什么原因 下一篇:段时间不看就会显示文件已过期或已被清理,怎么解决

返回主页:五金制品

本文网址:http://www.is2k.com/view-374203-1.html
    信息删除